HS won't launch

  • Hi there fellow Card playing people o7

    I've got an issue which is rather odd and i can't find any well written mac documentation therefore i try to ask here, maybe i'm lucky and find someone who knows a bit more about that stuff.

    • I tried to start HS via Battle.net App. Which tries to open the app. I can see that some icon in my dock tries to pop up there, but immediately vanishes. That happens twice. Before giving me the message that the game couldn't be started and refers me to this page: https://eu.battle.net/support/en/article/28441
    • I already tried to repair it. The issue persists.
    • I tried to open the hs app via the terminal which gives me this message:
      LSOpenURLsWithRole() failed for the application /Volumes/Bootcamp/Games/Hearthstone/Hearthstone.app with error -10810.

    And yes.. you may wondering why it's on my Bootcamp drive. I had the hs installed on Windows and i didn't want to download the whole thing again, so i booted mac, put the windows version of hs into the bnet app, let it repair and it downloaded the rest of the files which are needed for mac i. This shouldn't be and issue i guess? Except there're files which are called the same but still different on both OSses? (Something like that? I dunno.)

    The error page blizz refers me to says that my OS is maybe "outdated". That could also kinda be the case?
    I'm using MacOS 10.13.3 Beta, maybe it's not supported yet? Anything about that?

    Anyhow, if someone can help i would appreciate it.
    Thanks in advance.
  • Hey nevo,

    First, I recommend reinstalling the macOS version of Hearthstone. The Bootcamp drive will be formatted for NTFS. The macOS version of Hearthstone needs to be installed on a drive formatted either with HFS+ or APFS to run properly. Make sure Hearthstone is installed on a HFS+ or APFS formatted drive.

    You may also need to revert the macOS back to 10.13.2. Hearthstone does not support any OS that is in beta testing. There can be all sort of issues that could happen due to a beta OS.